<!doctype html>

<!--[if lt IE 7]><html lang="en-US" class="no-js lt-ie9 lt-ie8 lt-ie7"><![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" class="no-js"><!--<![endif]-->

	<head>
		<meta charset="utf-8">

				<meta http-equiv="X-UA-Compatible" content="IE=edge">

		<title>Catholic chaplain gives logical opposition to death penalty - Florida Catholic</title>

				<meta name="HandheldFriendly" content="True">
		<meta name="MobileOptimized" content="320">
		<meta name="viewport" content="width=device-width, initial-scale=1"/>
                
        <!--<script data-ad-client="ca-pub-1944936239245826" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>-->
		
		<script data-ad-client="ca-pub-3605524712622005" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>




<script src="https://ajax.googleapis.com/ajax/libs/webfont/1.6.16/webfont.js"></script>
<script>
  WebFont.load({
    google: {
      families: ['Montserrat']
    }
  });
</script>
        
        
        		
		<link rel="stylesheet" href="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/font-awesome-4.4.0/css/font-awesome.min.css">
        

				<link rel="apple-touch-icon" href="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/apple-touch-icon.png">
		<link rel="icon" href="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/favicon.png">
		<!--[if IE]>
			<link rel="shortcut icon" href="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/favicon.ico">
		<![endif]-->
        
        
        
        
				<meta name="msapplication-TileColor" content="#f01d4f">
		<meta name="msapplication-TileImage" content="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/win8-tile-icon.png">
            <meta name="theme-color" content="#121212">

		<link rel="pingback" href="https://thefloridacatholic.org/xmlrpc.php">

				
	<!-- This site is optimized with the Yoast SEO plugin v15.1.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://thefloridacatholic.org/2020/11/05/catholic-chaplain-gives-logical-opposition-to-death-penalty/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Catholic chaplain gives logical opposition to death penalty - Florida Catholic" />
	<meta property="og:description" content="ORLANDO&nbsp; |&nbsp; With decades of experience, a death row chaplain and well-known Catholic speaker used a virtual forum to focus on his most significant lifetime pursuit — raising awareness about the wrongness of America’s use of the death penalty. On Oct. 24, 2020, Dale Recinella, a Catholic correctional chaplain for Florida’s death row inmates, gave... Read more &raquo;" />
	<meta property="og:url" content="https://thefloridacatholic.org/2020/11/05/catholic-chaplain-gives-logical-opposition-to-death-penalty/" />
	<meta property="og:site_name" content="Florida Catholic" />
	<meta property="article:publisher" content="https://www.facebook.com/FloridaCatholic/" />
	<meta property="article:published_time" content="2020-11-05T13:24:57+00:00" />
	<meta property="article:modified_time" content="2020-11-05T13:24:58+00:00" />
	<meta property="og:image" content="https://thefloridacatholic.org/wp-content/uploads/2020/11/Screenshot-46.png" />
	<meta property="og:image:width" content="1920" />
	<meta property="og:image:height" content="1080" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://thefloridacatholic.org/#organization","name":"Florida Catholic Media","url":"https://thefloridacatholic.org/","sameAs":["https://www.facebook.com/FloridaCatholic/","https://www.instagram.com/floridacatholic/","https://www.linkedin.com/company/florida-catholic-media","https://www.youtube.com/channel/UCY3rUZiq2M--XtiJbQ3XUVw","https://twitter.com/floridacatholic"],"logo":{"@type":"ImageObject","@id":"https://thefloridacatholic.org/#logo","inLanguage":"en-US","url":"https://thefloridacatholic.org/wp-content/uploads/2020/09/download.png","width":225,"height":225,"caption":"Florida Catholic Media"},"image":{"@id":"https://thefloridacatholic.org/#logo"}},{"@type":"WebSite","@id":"https://thefloridacatholic.org/#website","url":"https://thefloridacatholic.org/","name":"Florida Catholic Media","description":"","publisher":{"@id":"https://thefloridacatholic.org/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://thefloridacatholic.org/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://thefloridacatholic.org/2020/11/05/catholic-chaplain-gives-logical-opposition-to-death-penalty/#primaryimage","inLanguage":"en-US","url":"https://thefloridacatholic.org/wp-content/uploads/2020/11/Screenshot-46.png","width":1920,"height":1080},{"@type":"WebPage","@id":"https://thefloridacatholic.org/2020/11/05/catholic-chaplain-gives-logical-opposition-to-death-penalty/#webpage","url":"https://thefloridacatholic.org/2020/11/05/catholic-chaplain-gives-logical-opposition-to-death-penalty/","name":"Catholic chaplain gives logical opposition to death penalty - Florida Catholic","isPartOf":{"@id":"https://thefloridacatholic.org/#website"},"primaryImageOfPage":{"@id":"https://thefloridacatholic.org/2020/11/05/catholic-chaplain-gives-logical-opposition-to-death-penalty/#primaryimage"},"datePublished":"2020-11-05T13:24:57+00:00","dateModified":"2020-11-05T13:24:58+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://thefloridacatholic.org/2020/11/05/catholic-chaplain-gives-logical-opposition-to-death-penalty/"]}]},{"@type":"Article","@id":"https://thefloridacatholic.org/2020/11/05/catholic-chaplain-gives-logical-opposition-to-death-penalty/#article","isPartOf":{"@id":"https://thefloridacatholic.org/2020/11/05/catholic-chaplain-gives-logical-opposition-to-death-penalty/#webpage"},"author":{"@id":"https://thefloridacatholic.org/#/schema/person/20a4427d55325c4cc98dc1f2aa74ac71"},"headline":"Catholic chaplain gives logical opposition to death penalty","datePublished":"2020-11-05T13:24:57+00:00","dateModified":"2020-11-05T13:24:58+00:00","mainEntityOfPage":{"@id":"https://thefloridacatholic.org/2020/11/05/catholic-chaplain-gives-logical-opposition-to-death-penalty/#webpage"},"publisher":{"@id":"https://thefloridacatholic.org/#organization"},"image":{"@id":"https://thefloridacatholic.org/2020/11/05/catholic-chaplain-gives-logical-opposition-to-death-penalty/#primaryimage"},"articleSection":"Florida,National,News","inLanguage":"en-US"},{"@type":"Person","@id":"https://thefloridacatholic.org/#/schema/person/20a4427d55325c4cc98dc1f2aa74ac71","name":"Maurice Beaulieu, Florida Catholic Media","image":{"@type":"ImageObject","@id":"https://thefloridacatholic.org/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/361f7dbdcc8708fb8cfb52c2eefc86ab?s=96&d=mm&r=g","caption":"Maurice Beaulieu, Florida Catholic Media"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<meta http-equiv="x-dns-prefetch-control" content="on">
<link href="https://app.ecwid.com" rel="preconnect" crossorigin />
<link href="https://ecomm.events" rel="preconnect" crossorigin />
<link href="https://d1q3axnfhmyveb.cloudfront.net" rel="preconnect" crossorigin />
<link href="https://dqzrr9k4bjpzk.cloudfront.net" rel="preconnect" crossorigin />
<link href="https://d3j0zfs7paavns.cloudfront.net" rel="preconnect" crossorigin>
<link rel="prefetch" href="https://app.ecwid.com/script.js?31356500&data_platform=wporg&lang=en" />
<link rel="prerender" href="https://thefloridacatholic.org/store/" />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Florida Catholic &raquo; Feed" href="https://thefloridacatholic.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Florida Catholic &raquo; Comments Feed" href="https://thefloridacatholic.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Florida Catholic &raquo; Catholic chaplain gives logical opposition to death penalty Comments Feed" href="https://thefloridacatholic.org/2020/11/05/catholic-chaplain-gives-logical-opposition-to-death-penalty/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thefloridacatholic.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://thefloridacatholic.org/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='ecwid-css-css'  href='https://thefloridacatholic.org/wp-content/plugins/ecwid-shopping-cart/css/frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='https://thefloridacatholic.org/wp-content/plugins/revslider/public/assets/css/settings.css' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Lato%3A400%2C700%2C400italic%2C700italic' type='text/css' media='all' />
<link rel='stylesheet' id='bones-stylesheet-css'  href='https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/css/style.css' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='bones-ie-only-css'  href='https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/css/ie.css' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://thefloridacatholic.org/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ecwidParams = {"useJsApiToOpenStoreCategoriesPages":"","storeId":"31356500"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/ecwid-shopping-cart/js/frontend.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/js/libs/modernizr.custom.min.js'></script>
<link rel='https://api.w.org/' href='https://thefloridacatholic.org/wp-json/' />
<link rel='shortlink' href='https://thefloridacatholic.org/?p=19175' />
<link rel="alternate" type="application/json+oembed" href="https://thefloridacatholic.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthefloridacatholic.org%2F2020%2F11%2F05%2Fcatholic-chaplain-gives-logical-opposition-to-death-penalty%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thefloridacatholic.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthefloridacatholic.org%2F2020%2F11%2F05%2Fcatholic-chaplain-gives-logical-opposition-to-death-penalty%2F&#038;format=xml" />
<script data-cfasync="false" data-no-optimize="1" type="text/javascript">
window.ec = window.ec || Object()
window.ec.config = window.ec.config || Object();
window.ec.config.enable_canonical_urls = true;

</script>
<script data-cfasync="false" type="text/javascript">
window.ec = window.ec || Object();
window.ec.config = window.ec.config || Object();
window.ec.config.store_main_page_url = 'https://thefloridacatholic.org/store/';		
</script><meta name="generator" content="Powered by Slider Revolution 5.4.6 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
<script type="text/javascript">function setREVStartSize(e){
				try{ var i=jQuery(window).width(),t=9999,r=0,n=0,l=0,f=0,s=0,h=0;					
					if(e.responsiveLevels&&(jQuery.each(e.responsiveLevels,function(e,f){f>i&&(t=r=f,l=e),i>f&&f>r&&(r=f,n=e)}),t>r&&(l=n)),f=e.gridheight[l]||e.gridheight[0]||e.gridheight,s=e.gridwidth[l]||e.gridwidth[0]||e.gridwidth,h=i/s,h=h>1?1:h,f=Math.round(h*f),"fullscreen"==e.sliderLayout){var u=(e.c.width(),jQuery(window).height());if(void 0!=e.fullScreenOffsetContainer){var c=e.fullScreenOffsetContainer.split(",");if (c) jQuery.each(c,function(e,i){u=jQuery(i).length>0?u-jQuery(i).outerHeight(!0):u}),e.fullScreenOffset.split("%").length>1&&void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0?u-=jQuery(window).height()*parseInt(e.fullScreenOffset,0)/100:void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0&&(u-=parseInt(e.fullScreenOffset,0))}f=u}else void 0!=e.minHeight&&f<e.minHeight&&(f=e.minHeight);e.c.closest(".rev_slider_wrapper").css({height:f})					
				}catch(d){console.log("Failure at Presize of Slider:"+d)}
			};</script>
		<style type="text/css" id="wp-custom-css">
			.iframe-container{
  position: relative;
  width: 100%;
  padding-bottom: 56.25%; 
  height: 0;
}
.iframe-container iframe{
  position: absolute;
  top:0;
  left: 0;
  width: 100%;
  height: 100%;
}		</style>
				
				
		<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-82857878-1', 'auto');
  ga('send', 'pageview');

</script>

	<script data-ad-client="ca-pub-1944936239245826" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

				
		<!-- Begin Constant Contact Active Forms -->
<script> var _ctct_m = "caca7b8a7088c3b9ba4cc094d4703786"; </script>
<script id="signupScript" src="//static.ctctcdn.com/js/signup-form-widget/current/signup-form-widget.min.js" async defer></script>
<!-- End Constant Contact Active Forms -->

	</head>

	<body data-rsssl=1 class="post-template-default single single-post postid-19175 single-format-standard" itemscope itemtype="http://schema.org/WebPage">

		<div id="container">
		
		
			<header class="header" role="banner" itemscope itemtype="http://schema.org/WPHeader">
            
								<div class="flc-mob-menu">

					<input type="checkbox" id="flc-mob-trigger">
        				<label class="flc-nav-btn" for="flc-mob-trigger"><span></span></label>

					
						<ul id="menu-mobile-nav" class="flc-mob-nav cf"><li id="menu-item-16623" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-16623"><a href="https://thefloridacatholic.org/">Home</a></li>
<li id="menu-item-16624" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16624"><a href="https://thefloridacatholic.org/sunday-word/">Sunday Word</a></li>
<li id="menu-item-16625" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16625"><a href="https://thefloridacatholic.org/florida-bishops/">Florida Bishops</a></li>
<li id="menu-item-16626" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16626"><a href="https://thefloridacatholic.org/local-diocese/">Local Diocese</a></li>
<li id="menu-item-16627" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16627"><a href="https://thefloridacatholic.org/article-request/">Article Request</a></li>
<li id="menu-item-16628" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16628"><a href="https://thefloridacatholic.org/give-feedback/">Give Feedback</a></li>
<li id="menu-item-16629" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16629"><a href="https://thefloridacatholic.org/about-us/">About Us</a></li>
<li id="menu-item-16630" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16630"><a href="https://thefloridacatholic.org/classifieds/">Classifieds</a></li>
<li id="menu-item-16636" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16636"><a href="https://secure.givelively.org/donate/florida-catholic-inc/long-sleeve-relief">Donate to Long-Sleeve Relief</a></li>
<li id="menu-item-16631" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16631"><a href="https://thefloridacatholic.org/newsletter/">Monthly Newsletter</a></li>
<li id="menu-item-16632" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16632"><a href="http://digital.thefloridacatholic.org/">Get Our e-Edition</a></li>
<li id="menu-item-16633" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16633"><a href="https://thefloridacatholic.org/advertising/">Advertise with Us</a></li>
<li id="menu-item-16634" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16634"><a href="https://thefloridacatholic.org/address-change/">Address Change</a></li>
<li id="menu-item-16635" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16635"><a href="https://thefloridacatholic.org/subscribe/">Subscribe or Renew</a></li>
</ul>
					

				</div>

						
			
            <div id="flc-top" class="wrap cf">
            
				<div class="flc-header-logo m-all t-305 d-4of5">
				<a href="https://thefloridacatholic.org" rel="nofollow">                    
                    <img width="55%" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/flc_logo.svg" /></a>
                </div>
                    
                 <div class="flc-header-right m-all t-205 d-1of5">
                    
                  <div id="flc-search">
                      <form role="search" method="get" id="searchform" class="searchform" action="https://thefloridacatholic.org/">
    <div>
        <label for="s" class="screen-reader-text">Search for:</label>
        <input type="search" id="s" name="s" value="" />

        <button type="submit" id="searchsubmit" >Search</button>
    </div>
</form>                    </div>
                    <i class="fa fa-phone flc-head-blue"></i> 407-373-0075 <span class="flc-head-blue">|</span> 888-275-9953 <br />
                    
                    <div class="flc-head-connect">
                    	Connect with us
                    	<ul>
                    		<li><a href="http://www.facebook.com/FloridaCatholic/" target="_blank"><i class="fa fa-facebook"></i></a></li>
                            <li><a href="https://twitter.com/floridacatholic" target="_blank"><i class="fa fa-twitter"></i></a></li>
							<li><a href="https://www.youtube.com/channel/UCY3rUZiq2M--XtiJbQ3XUVw" target="_blank"><i class="fa fa-youtube"></i></a></li>
                            <li><a href="https://thefloridacatholic.org/feed/" target="_blank"><i class="fa fa-rss"></i></a></li>
                    	</ul>

                     </div>
                        
                    </div>
                    
 
             </div>
             
             <div class="flc-navigation">

				<div id="inner-header" class="wrap cf">

		


					<nav role="navigation" itemscope itemtype="http://schema.org/SiteNavigationElement">
						<ul id="menu-main-nav" class="nav top-nav cf"><li id="menu-item-44" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-44"><a href="https://thefloridacatholic.org/">Home</a></li>
<li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30"><a href="https://thefloridacatholic.org/sunday-word/">Sunday Word</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29"><a href="https://thefloridacatholic.org/florida-bishops/">Florida Bishops</a></li>
<li id="menu-item-2122" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2122"><a href="https://thefloridacatholic.org/local-diocese/">Local Diocese</a></li>
<li id="menu-item-27" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27"><a href="https://thefloridacatholic.org/article-request/">Article Request</a></li>
<li id="menu-item-26" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26"><a href="https://thefloridacatholic.org/give-feedback/">Give Feedback</a></li>
<li id="menu-item-25" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25"><a href="https://thefloridacatholic.org/about-us/">About Us</a></li>
<li id="menu-item-2106" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2106"><a href="https://thefloridacatholic.org/classifieds/">Classifieds</a></li>
</ul>						
					</nav>

				</div>
                
                </div>

			</header>

			<div id="content">
			<div id="inner-content" class="wrap cf">

			<div id="flc-body">
  

					<main id="main" class="m-all t-all d-all cf" role="main" itemscope itemprop="mainContentOfPage" itemtype="http://schema.org/Blog">

						
							
              
              <article id="post-19175" class="cf post-19175 post type-post status-publish format-standard has-post-thumbnail hentry category-news-florida category-news-national category-news" role="article" itemscope itemprop="blogPost" itemtype="http://schema.org/BlogPosting">
			  
			  <div class="flc-hp-topfeatimage">
			   <img width="883" height="385" src="https://thefloridacatholic.org/wp-content/cache/thumbnails/2020/11/Screenshot-46-883x385-c.png" class="attachment-883x385x1 size-883x385x1 wp-post-image" alt="" />						 <p style="padding-left:24px; color:#8d8d8d;"><em>Dale Recinella, a Catholic chaplain for Florida death row inmates. (SCREENSHOT)</em></p> 
										</div>
                <header class="article-header entry-header">

                  <h1 class="entry-title single-title" itemprop="headline" rel="bookmark">Catholic chaplain gives logical opposition to death penalty</h1>

                   <p class="flc-blog-byline">By Maurice Beaulieu | November 5, 2020</p>

                </header> 
                <section class="entry-content cf" itemprop="articleBody">
                  
<p><strong>ORLANDO</strong>&nbsp; |&nbsp; With decades of experience, a death row chaplain and well-known Catholic speaker used a virtual forum to focus on his most significant lifetime pursuit — raising awareness about the wrongness of America’s use of the death penalty.</p>



<p>On Oct. 24, 2020, Dale Recinella, a Catholic correctional chaplain for Florida’s death row inmates, gave a virtual presentation for the 34th annual Culture of Life Conference orchestrated by the Respect Life Office of the Diocese of Palm Beach, in conjunction with the Florida Conference of Catholic Bishops. Recinella’s presentation — one of 11 at the conference — encompassed the importance of maintaining all life, from conception to natural death. Using his genuine passion of opposing the death penalty, Recinella spoke to his viewers fervently and seriously.&nbsp;</p>



<p>“As Catholic Christians positioned in the opening throes of the third millennium, we are first and foremost a bulwark of the God-given dignity of every human life, the God-given value of human life,” he said. “We are the guardians of the culture of life. We have to be because we find ourselves and this faith stance under constant pressure and assault from the culture of death.”&nbsp;</p>



<p>He follows Pope Francis’ outlook why all human life, regardless of what atrocities they may have committed, deserve respect and value to not have their lives ended by state powers.&nbsp;</p>



<p>“Capital punishment is indeed a respect life issue and here in Florida, the Catholic Bishops have given us tremendous guidance on this issue. Pope Francis has now revised paragraph 22:67 of the Catholic Catechism,” Recinella said. “(The pope’s) thinking is that today capital punishment is unacceptable however serious the condemned’s crime may have been. ‘The death penalty, regardless of the means of execution, entails cruel, inhumane, and degrading treatment. Furthermore, it is to be rejected to the defective selectivity of the justice system and in the face of the possibility of judicial error.’” &nbsp;</p>



<p>One of Recinella’s points touched “one of the most consistent and pervasive myths” about the death penalty — that it is financially “cheaper” than life in prison.&nbsp;</p>



<p>“Nothing could be further from the truth,” he said. “A critical part of perpetuating that myth is the notion that if we just execute people quickly it would be cheaper than putting them in prison. The problem is that even with our existing system of appeals we do not have a good record for putting only guilty people on death row.”</p>



<p>He went on to discuss how the death penalty is not an “error free system,” like many might assume. “Since 1973, more than 173 people who had been wrongfully convicted and sentenced to death in the U.S. have been exonerated. (In Florida) in that same time frame, 30 people have been exonerated and released from our death row, more than any other jurisdiction.”&nbsp;</p>



<p>Another myth Recinella expounded upon was that lethal injection provides a “painless and humane” method of ending a death row inmate’s life. Autopsies conducted on lethally injected inmates suggested the prisoners suffered greatly and with horrible pain. “For years in my death penalty talks in Florida, I have said the fact of the matter is there is no nice way to kill people. Now I prefer the way Pope Francis says it: ‘However administered, the death penalty is an attack on the inviolability and the dignity of the person.’”</p>



<p>Many people believe that the presence of the death penalty in a state will deter criminals from engaging in terrible crimes. However, Recinella said, “It’s just not real.” In fact, the National Academy of Science “have concluded that past studies have failed to prove or disprove a deterrent effect by capital punishment.” &nbsp;</p>



<p>Recinella’s closed his lecture proving that racial bias plays a major part in America’s involvement with the death penalty. “In places where executions are prevalent today, extra judicial lynching’s used to be quite common. Lynchings, of course, were often racially motivated. The racially biased process of lynching’s laid the foundation for the racially biased death penalty,” he said. “The death penalty is a direct descendant of lynching’s and other forms of racial violence and racial oppression in America.&nbsp;</p>



<p>In his conclusion, Recinella used a Catholic saint to solidify his message. “In his masterpiece of integration of Western theology and philosophy, the ‘<em>Summa Theologica</em>,’ St. Thomas Aquinas stated clearly and point blank that the execution of an innocent person is intrinsically evil.”&nbsp;</p>



<p>As a death row chaplain, Recinella has witnessed many executions, including those of men guilty of their crimes. But he has also “witnessed the execution of a person I was absolutely convinced was innocent.” Yet, in every execution, one thing is always for certain: an execution offends respect for human life.</p>



<p>“I believe all us pro-life Catholics in Florida have our marching orders. We need to end the use of the death penalty and the use of abortion in the Sunshine State. That is our mission,” Recinella said. “That is our call. And that is at the core of our stand for respect life.” </p>
                </section> 
                <footer class="article-footer">

                  filed under: <a href="https://thefloridacatholic.org/category/news/news-florida/" rel="category tag">Florida</a>, <a href="https://thefloridacatholic.org/category/news/news-national/" rel="category tag">National</a>, <a href="https://thefloridacatholic.org/category/news/" rel="category tag">News</a>
                  
                </footer> 
                
              </article> 
						
						
             
                    
							   
							   
							   
							   

<!--<p>ADVERTISEMENT</p>-->

  
<div class="cf"></div>
 
 <div class="flc-mobile-ad m-all">
   <a href="https://thefloridacatholic.org/candidate-questionnaire-poll/" target="_blank"> <img src="https://thefloridacatholic.org/wp-content/uploads/2020/07/CQPmeme1.jpg" /></a>
</div><div class="cf"></div>

 



							</article>

						</main>
                        
                   </div>

						
	 				
                <!--
                <div id="sidebar1" class="sidebar m-all t-1of3 d-2of7 last-col cf" role="complementary">

					
						
					
						
						<div class="no-widgets">
							<p></p>
						</div>

					
				</div>
                -->


	<div id="flc-sidebar">
                        
                        	<div id="flc-side-featured">

                            									
																
								<a href="/newsletter/"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/dose_of_faith-icon.png" /><br/>Monthly Newsletter</a>
								
								<a href="http://digital.thefloridacatholic.org/" target="_blank"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/e-edtion-free-icon.png" /><br />Get Our<br />e-Edition</a>
								
								
								
								
								
								<a href="/advertising/"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/flc-banner-links4.png" />Advertise<br />with us</a>
								
								<a href="/address-change/"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/flc-banner-links1.png" /><br/>Address<br /> Change</a>
								
								
								
								<a href="/store/"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/flc-banner-links3.png" /><br/>Subscribe<br />or Renew</a>
								
								<a href="/subscribe/"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/donate-icon.png" /><br/>Donate</a>
								
								
                                
                               
                                   
                                   <div class="cf"></div>
                                   
                            
                            
                            </div>						

							
                            <div id="flc-side-ads">
							
							
														
							                            
                            <p>ADVERTISEMENT</p>
															  															 <div class="flc-right-ad">
   <a href="https://thefloridacatholic.org/candidate-questionnaire-poll/" target="_blank"> <img src="https://thefloridacatholic.org/wp-content/uploads/2020/07/CQPmeme1.jpg" /></a>
</div>

<div class="flc-right-ad">
   <a href="https://www.gotmills3.com/" target="_blank"> <img src="https://thefloridacatholic.org/wp-content/uploads/2020/08/300x300-1.jpg" /></a>
</div>

<div class="flc-right-ad">
   <a href="http://digital.thefloridacatholic.org/" target="_blank"> <img src="https://thefloridacatholic.org/wp-content/uploads/2020/08/300x300-new.jpg" /></a>
</div>

<div class="flc-right-ad">
   <a href="https://thefloridacatholic.org/newsletter/" target="_blank"> <img src="https://thefloridacatholic.org/wp-content/uploads/2020/08/300x300-px-1.jpg" /></a>
</div>

                             
                            </div>							
							<center>
							
								<img  src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/text2join.jpg" alt="Text FLCATHOLIC to 22828 to get our e-Edition!" />
							
							</center>
							
							<center>
								<img src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/platinum-seal2020.png" alt="Guidestar Platinum Seal of Transparency" style=" margin-top:25px;"/>
							</center>

						</div>                        
                        <div class="cf"></div>
				</div>

			</div>

﻿            <div id="flc-footer-esignup" >                        	<div class="wrap cf">                	                    <h3>Sign-up for our <a href="https://thefloridacatholic.org/newsletter-signup/" target="_blank">Newsletter</a></h3><p>Enter your email to be a part of our mailing list. Don’t worry, we don’t share them!</p>                    <a href="https://thefloridacatholic.org/newsletter-signup/" class="flc-footer-esignup-btn" target="_blank">Join our list!</a><br />                                    </div>                                                                                             </div>  			            <div id="flc-footer-ways2sub">               	                <div class="wrap cf">                               <h3>Ways to <a href="https://thefloridacatholic.org/newsletter-signup/">Subscribe</a></h3>                              </div>                              <div class="wrap cf">                                                	<div class="m-all t-1of3 d-1of3 ">                                        <a href="https://thefloridacatholic.org/store/"><img src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/flc-footer-laptop.jpg" /></a>                <h4>Option 1</h4>                                <p>Fill out the online subscription form <a href="https://thefloridacatholic.org/newsletter-signup/">here!</a><br />Or call toll-free 1-888-275-9953</p>						</div>					<div class="m-all t-1of3 d-1of3">                                        <img src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/flc-footer-letter.jpg" /></a>					<h4>Option 2</h4>                                                            Send a check payable to: <strong>Florida Catholic</strong><br />PO Box 4993, Orlando, FL 32802-4993					</div>					<div class="m-all t-1of3 d-1of3">					<a href="https://digital.thefloridacatholic.org/"><img src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/flc-footer-tablet.jpg" /></a>					<h4>Option 3</h4><p>Subscribe to our <strong>e-Edition</strong> and enjoy<br />Catholic news on any browser.</p>					</div>                                </div>                                    </div>                                     <div class="wrap cf" style="text-align:center;">		<script type='text/javascript' src='https://www.rapidscansecure.com/siteseal/siteseal.js?code=69,AAC232D0625E9870452DDDA4BB6A36A20E72F9E3'></script>		</div>                        	<footer class="footer" role="contentinfo" itemscope itemtype="http://schema.org/WPFooter">				<div id="inner-footer" class="wrap cf">					<nav role="navigation">											</nav>					<p class="source-org copyright">&copy; 2020 Florida Catholic. All rights reserved. <a href="https://thefloridacatholic.org/classifieds/" target="_blank">Classifieds</a> | <a href="https://thefloridacatholic.org/privacy-statement/">Privacy</a>                                        <div class="flc-connect">                    	Connect with us                    	<ul>                    		<li><a href="http://www.facebook.com/FloridaCatholic/" target="_blank"><i class="fa fa-facebook"></i></a></li>                            <li><a href="https://twitter.com/floridacatholic" target="_blank"><i class="fa fa-twitter"></i></a></li>							<li><a href="https://www.youtube.com/channel/UCY3rUZiq2M--XtiJbQ3XUVw" target="_blank"><i class="fa fa-youtube"></i></a></li>                            <li><a href="https://thefloridacatholic.org/feed/" target="_blank"><i class="fa fa-rss"></i></a></li>                                                	</ul>                    </div>				</div>			</footer>		</div>				<script type='text/javascript' src='https://thefloridacatholic.org/wp-includes/js/jquery/ui/widget.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/js/scripts.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-includes/js/wp-embed.min.js'></script>
	<script src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/js/storepage.js"></script>			<!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com --><!--<script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-account="86295" data-user="76738" async></script>--><!-- / https://optinmonster.com -->		</body></html> <!-- end of site. what a ride! -->