<!doctype html>

<!--[if lt IE 7]><html lang="en-US" class="no-js lt-ie9 lt-ie8 lt-ie7"><![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" class="no-js"><!--<![endif]-->

	<head>
		<meta charset="utf-8">

				<meta http-equiv="X-UA-Compatible" content="IE=edge">

		<title>Faith leaders call for &#039;Day of Mourning and Lament&#039; for victims of virus - Florida Catholic</title>

				<meta name="HandheldFriendly" content="True">
		<meta name="MobileOptimized" content="320">
		<meta name="viewport" content="width=device-width, initial-scale=1"/>
                
        


<script src="https://ajax.googleapis.com/ajax/libs/webfont/1.6.16/webfont.js"></script>
<script>
  WebFont.load({
    google: {
      families: ['Montserrat']
    }
  });
</script>
        
        
        		
		<link rel="stylesheet" href="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/font-awesome-4.4.0/css/font-awesome.min.css">
        

				<link rel="apple-touch-icon" href="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/apple-touch-icon.png">
		<link rel="icon" href="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/favicon.png">
		<!--[if IE]>
			<link rel="shortcut icon" href="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/favicon.ico">
		<![endif]-->
        
        
        
        
				<meta name="msapplication-TileColor" content="#f01d4f">
		<meta name="msapplication-TileImage" content="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/win8-tile-icon.png">
            <meta name="theme-color" content="#121212">

		<link rel="pingback" href="https://thefloridacatholic.org/xmlrpc.php">

				
	<!-- This site is optimized with the Yoast SEO plugin v14.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://thefloridacatholic.org/2020/05/29/faith-leaders-call-for-day-of-mourning-and-lament-for-victims-of-virus/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Faith leaders call for &#039;Day of Mourning and Lament&#039; for victims of virus - Florida Catholic" />
	<meta property="og:description" content="SILVER SPRING, Md. | The Leadership Conference of Women Religious said May 27 it will join a group of over 100 national faith leaders &#8212; from Christian, Jewish and Muslim traditions &#8212; who have called for a National Day of Mourning and Lament June 1 for those who have died from COVID-19. The group is... Read more &raquo;" />
	<meta property="og:url" content="https://thefloridacatholic.org/2020/05/29/faith-leaders-call-for-day-of-mourning-and-lament-for-victims-of-virus/" />
	<meta property="og:site_name" content="Florida Catholic" />
	<meta property="article:published_time" content="2020-05-29T22:32:01+00:00" />
	<meta property="article:modified_time" content="2020-05-29T22:32:05+00:00" />
	<meta property="og:image" content="https://thefloridacatholic.org/wp-content/uploads/2020/05/20200528T1520-140-CNS-DAY-MOURNING-LAMENT-COVID-scaled.jpg" />
	<meta property="og:image:width" content="2560" />
	<meta property="og:image:height" content="1707" />
	<meta name="twitter:card" content="summary_large_image" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://thefloridacatholic.org/#website","url":"https://thefloridacatholic.org/","name":"Florida Catholic","description":"","potentialAction":[{"@type":"SearchAction","target":"https://thefloridacatholic.org/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://thefloridacatholic.org/2020/05/29/faith-leaders-call-for-day-of-mourning-and-lament-for-victims-of-virus/#primaryimage","inLanguage":"en-US","url":"https://thefloridacatholic.org/wp-content/uploads/2020/05/20200528T1520-140-CNS-DAY-MOURNING-LAMENT-COVID-scaled.jpg","width":2560,"height":1707,"caption":"Roberto Arias of Everett, Mass., prepares a grave for burial May 27, 2020, during the coronavirus pandemic. (CNS photo/Brian Snyder, Reuters) See DAY-MOURNING-LAMENT-COVID May 28, 2020."},{"@type":"WebPage","@id":"https://thefloridacatholic.org/2020/05/29/faith-leaders-call-for-day-of-mourning-and-lament-for-victims-of-virus/#webpage","url":"https://thefloridacatholic.org/2020/05/29/faith-leaders-call-for-day-of-mourning-and-lament-for-victims-of-virus/","name":"Faith leaders call for 'Day of Mourning and Lament' for victims of virus - Florida Catholic","isPartOf":{"@id":"https://thefloridacatholic.org/#website"},"primaryImageOfPage":{"@id":"https://thefloridacatholic.org/2020/05/29/faith-leaders-call-for-day-of-mourning-and-lament-for-victims-of-virus/#primaryimage"},"datePublished":"2020-05-29T22:32:01+00:00","dateModified":"2020-05-29T22:32:05+00:00","author":{"@id":"https://thefloridacatholic.org/#/schema/person/73171231c9bd8b292bed27dce2415b1d"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://thefloridacatholic.org/2020/05/29/faith-leaders-call-for-day-of-mourning-and-lament-for-victims-of-virus/"]}]},{"@type":["Person"],"@id":"https://thefloridacatholic.org/#/schema/person/73171231c9bd8b292bed27dce2415b1d","name":"Ann Borowski Slade","image":{"@type":"ImageObject","@id":"https://thefloridacatholic.org/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/fd8e584a9bda8d3b9c14045de8770051?s=96&d=mm&r=g","caption":"Ann Borowski Slade"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Florida Catholic &raquo; Feed" href="https://thefloridacatholic.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Florida Catholic &raquo; Comments Feed" href="https://thefloridacatholic.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Florida Catholic &raquo; Faith leaders call for &#8216;Day of Mourning and Lament&#8217; for victims of virus Comments Feed" href="https://thefloridacatholic.org/2020/05/29/faith-leaders-call-for-day-of-mourning-and-lament-for-victims-of-virus/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thefloridacatholic.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://thefloridacatholic.org/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wc-block-style-css'  href='https://thefloridacatholic.org/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='https://thefloridacatholic.org/wp-content/plugins/revslider/public/assets/css/settings.css' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='woocommerce-layout-css'  href='https://thefloridacatholic.org/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://thefloridacatholic.org/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='https://thefloridacatholic.org/wp-content/plugins/woocommerce/assets/css/woocommerce.css' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Lato%3A400%2C700%2C400italic%2C700italic' type='text/css' media='all' />
<link rel='stylesheet' id='sv-wc-payment-gateway-payment-form-css'  href='https://thefloridacatholic.org/wp-content/plugins/woocommerce-gateway-authorize-net-cim/vendor/skyverge/wc-plugin-framework/woocommerce/payment-gateway/assets/css/frontend/sv-wc-payment-gateway-payment-form.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='popup-maker-site-css'  href='//thefloridacatholic.org/wp-content/uploads/pum/pum-site-styles.css?generated=1590111640' type='text/css' media='all' />
<link rel='stylesheet' id='bones-stylesheet-css'  href='https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/css/style.css' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='bones-ie-only-css'  href='https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/css/ie.css' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://thefloridacatholic.org/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/js/libs/modernizr.custom.min.js'></script>
<link rel='https://api.w.org/' href='https://thefloridacatholic.org/wp-json/' />
<link rel='shortlink' href='https://thefloridacatholic.org/?p=17047' />
<link rel="alternate" type="application/json+oembed" href="https://thefloridacatholic.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthefloridacatholic.org%2F2020%2F05%2F29%2Ffaith-leaders-call-for-day-of-mourning-and-lament-for-victims-of-virus%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thefloridacatholic.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthefloridacatholic.org%2F2020%2F05%2F29%2Ffaith-leaders-call-for-day-of-mourning-and-lament-for-victims-of-virus%2F&#038;format=xml" />
	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<meta name="generator" content="Powered by Slider Revolution 5.4.6 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
<script type="text/javascript">function setREVStartSize(e){
				try{ var i=jQuery(window).width(),t=9999,r=0,n=0,l=0,f=0,s=0,h=0;					
					if(e.responsiveLevels&&(jQuery.each(e.responsiveLevels,function(e,f){f>i&&(t=r=f,l=e),i>f&&f>r&&(r=f,n=e)}),t>r&&(l=n)),f=e.gridheight[l]||e.gridheight[0]||e.gridheight,s=e.gridwidth[l]||e.gridwidth[0]||e.gridwidth,h=i/s,h=h>1?1:h,f=Math.round(h*f),"fullscreen"==e.sliderLayout){var u=(e.c.width(),jQuery(window).height());if(void 0!=e.fullScreenOffsetContainer){var c=e.fullScreenOffsetContainer.split(",");if (c) jQuery.each(c,function(e,i){u=jQuery(i).length>0?u-jQuery(i).outerHeight(!0):u}),e.fullScreenOffset.split("%").length>1&&void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0?u-=jQuery(window).height()*parseInt(e.fullScreenOffset,0)/100:void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0&&(u-=parseInt(e.fullScreenOffset,0))}f=u}else void 0!=e.minHeight&&f<e.minHeight&&(f=e.minHeight);e.c.closest(".rev_slider_wrapper").css({height:f})					
				}catch(d){console.log("Failure at Presize of Slider:"+d)}
			};</script>
		
				
		<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-82857878-1', 'auto');
  ga('send', 'pageview');

</script>

	<script data-ad-client="ca-pub-1944936239245826" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

		
	</head>

	<body data-rsssl=1 class="post-template-default single single-post postid-17047 single-format-standard theme-floridacatholic2018 woocommerce-no-js" itemscope itemtype="http://schema.org/WebPage">

		<div id="container">
		
		<style>
	
		.FLC-Corona-Warning {
			width:100%;
			background-color:yellow;
			color:#000;
			padding:10px 60px;
		}
		
		</style>
		
		<div class="FLC-Corona-Warning">
			<p>Dear readers: There will be no print editions of the Florida Catholic right now. Instead, we offer the <a href="https://digital.thefloridacatholic.org/">digital editions of the paper</a> free of charge in the interim. Visit us each week to stay on top of news during this ongoing, global crisis. Please click on the envelope in the right hand corner of the e-Edition to receive an e-mail notification of a new edition.
			</p>
			
					</div>

			<header class="header" role="banner" itemscope itemtype="http://schema.org/WPHeader">
            
								<div class="flc-mob-menu">

					<input type="checkbox" id="flc-mob-trigger">
        				<label class="flc-nav-btn" for="flc-mob-trigger"><span></span></label>

					
						<ul id="menu-mobile-nav" class="flc-mob-nav cf"><li id="menu-item-16623" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-16623"><a href="https://thefloridacatholic.org/">Home</a></li>
<li id="menu-item-16624" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16624"><a href="https://thefloridacatholic.org/sunday-word/">Sunday Word</a></li>
<li id="menu-item-16625" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16625"><a href="https://thefloridacatholic.org/florida-bishops/">Florida Bishops</a></li>
<li id="menu-item-16626" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16626"><a href="https://thefloridacatholic.org/local-diocese/">Local Diocese</a></li>
<li id="menu-item-16627" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16627"><a href="https://thefloridacatholic.org/article-request/">Article Request</a></li>
<li id="menu-item-16628" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16628"><a href="https://thefloridacatholic.org/give-feedback/">Give Feedback</a></li>
<li id="menu-item-16629" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16629"><a href="https://thefloridacatholic.org/about-us/">About Us</a></li>
<li id="menu-item-16630" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16630"><a href="https://thefloridacatholic.org/classifieds/">Classifieds</a></li>
<li id="menu-item-16636" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16636"><a href="https://secure.givelively.org/donate/florida-catholic-inc/long-sleeve-relief">Donate to Long-Sleeve Relief</a></li>
<li id="menu-item-16631" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16631"><a href="https://thefloridacatholic.org/newsletter/">Monthly Newsletter</a></li>
<li id="menu-item-16632" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16632"><a href="http://digital.thefloridacatholic.org/">Get Our e-Edition</a></li>
<li id="menu-item-16633" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16633"><a href="https://thefloridacatholic.org/advertising/">Advertise with Us</a></li>
<li id="menu-item-16634" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16634"><a href="https://thefloridacatholic.org/address-change/">Address Change</a></li>
<li id="menu-item-16635" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16635"><a href="https://thefloridacatholic.org/subscribe/">Subscribe or Renew</a></li>
</ul>
					

				</div>

						
			
            <div id="flc-top" class="wrap cf">
            
				<div class="flc-header-logo m-all t-305 d-4of5">
				<a href="https://thefloridacatholic.org" rel="nofollow">                    
                    <img width="55%" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/flc_logo.svg" /></a>
                </div>
                    
                 <div class="flc-header-right m-all t-205 d-1of5">
                    
                  <div id="flc-search">
                      <form role="search" method="get" id="searchform" class="searchform" action="https://thefloridacatholic.org/">
    <div>
        <label for="s" class="screen-reader-text">Search for:</label>
        <input type="search" id="s" name="s" value="" />

        <button type="submit" id="searchsubmit" >Search</button>
    </div>
</form>                    </div>
                    <i class="fa fa-phone flc-head-blue"></i> 407-373-0075 <span class="flc-head-blue">|</span> 888-275-9953 <br />
                    
                    <div class="flc-head-connect">
                    	Connect with us
                    	<ul>
                    		<li><a href="http://www.facebook.com/FloridaCatholic/" target="_blank"><i class="fa fa-facebook"></i></a></li>
                            <li><a href="https://twitter.com/floridacatholic" target="_blank"><i class="fa fa-twitter"></i></a></li>
                            <li><a href="https://thefloridacatholic.org/feed/" target="_blank"><i class="fa fa-rss"></i></a></li>
                    	</ul>

                     </div>
                        
                    </div>
                    
 
             </div>
             
             <div class="flc-navigation">

				<div id="inner-header" class="wrap cf">

		


					<nav role="navigation" itemscope itemtype="http://schema.org/SiteNavigationElement">
						<ul id="menu-main-nav" class="nav top-nav cf"><li id="menu-item-44" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-44"><a href="https://thefloridacatholic.org/">Home</a></li>
<li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30"><a href="https://thefloridacatholic.org/sunday-word/">Sunday Word</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29"><a href="https://thefloridacatholic.org/florida-bishops/">Florida Bishops</a></li>
<li id="menu-item-2122" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2122"><a href="https://thefloridacatholic.org/local-diocese/">Local Diocese</a></li>
<li id="menu-item-27" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27"><a href="https://thefloridacatholic.org/article-request/">Article Request</a></li>
<li id="menu-item-26" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26"><a href="https://thefloridacatholic.org/give-feedback/">Give Feedback</a></li>
<li id="menu-item-25" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25"><a href="https://thefloridacatholic.org/about-us/">About Us</a></li>
<li id="menu-item-2106" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2106"><a href="https://thefloridacatholic.org/classifieds/">Classifieds</a></li>
</ul>						
					</nav>

				</div>
                
                </div>

			</header>

			<div id="content">
			<div id="inner-content" class="wrap cf">

			<div id="flc-body">
  

					<main id="main" class="m-all t-all d-all cf" role="main" itemscope itemprop="mainContentOfPage" itemtype="http://schema.org/Blog">

						
							
              
              <article id="post-17047" class="cf post-17047 post type-post status-publish format-standard has-post-thumbnail hentry category-national-and-international tag-covid19 tag-faith-leaders" role="article" itemscope itemprop="blogPost" itemtype="http://schema.org/BlogPosting">
			  
			  <div class="flc-hp-topfeatimage">
			   <img width="883" height="385" src="https://thefloridacatholic.org/wp-content/cache/thumbnails/2020/05/20200528T1520-140-CNS-DAY-MOURNING-LAMENT-COVID-scaled-883x385-c.jpg" class="attachment-883x385x1 size-883x385x1 wp-post-image" alt="" />						 <p style="padding-left:24px; color:#8d8d8d;"><em>Roberto Arias of Everett, Mass., prepares a grave for burial May 27, 2020, during the coronavirus pandemic. (CNS photo/Brian Snyder, Reuters) </em></p> 
										</div>
                <header class="article-header entry-header">

                  <h1 class="entry-title single-title" itemprop="headline" rel="bookmark">Faith leaders call for &#8216;Day of Mourning and Lament&#8217; for victims of virus</h1>

                   <p class="flc-blog-byline">By Catholic News Service | May 29, 2020</p>

                </header> 
                <section class="entry-content cf" itemprop="articleBody">
                  
<p><strong>SILVER SPRING, Md. </strong>| The Leadership Conference of Women Religious said May 27 it will join a group of over 100 national faith leaders &#8212; from Christian, Jewish and Muslim traditions &#8212; who have called for a National Day of Mourning and Lament June 1 for those who have died from COVID-19.</p>



<p>The group is urging federal, state and local elected officials to observe the day as well, which will be marked by marked by moments of silence, lowering of flags, interfaith vigils, ringing of bells and civic memorials.</p>



<p>LCWR, based in the Washington suburb of Silver Spring, said it asked its more than 1,300 members to invite the more than 40,000 Catholic sisters they represent to participate &#8220;in these actions of grieving and lament.&#8221;</p>



<p>&#8220;The lament will also acknowledge the hard truth this country has learned during this pandemic &#8212; that suffering has been unequal,&#8221; LCWR said in statement. &#8220;Elders, black and brown neighbors, native communities, refugees and immigrants have borne disproportionately the brunt of sickness and death.</p>



<p>&#8220;The faith leaders underscore that the healing of the nation must face the brokenness of its democracy as they call for the repair of the injustices this pandemic has revealed.&#8221;</p>



<p>Each faith tradition will incorporate &#8220;an action of lament&#8221; into its traditional services. &#8220;Together these faith traditions will name, honor and offer tributes to the lives, families and communities of those who have died,&#8221; LCWR said.</p>



<p>For Christians, it will be during Pentecost Sunday May 31, which commemorates &#8220;when the first Christians were given courage through the reception of the Holy Spirit.&#8221;</p>



<p>On May 29, with Ramadan finished, Muslims will remember the reception of the Quran. On May 29 and May 30, Jews will remember God’s covenant as they celebrate Shavuot and read their Yizkhor, or remembrance, prayers.</p>



<p>&#8220;We stand in solidarity with our sisters and brothers from so many faith traditions as we not only honor those who have lost their lives in the pandemic, but also call for the country to examine the injustices and inequities so starkly shown to us through this crisis,&#8221; said Sister Carol Zinn, a Sister of St. Joseph, who is executive director of LCWR.</p>



<p>&#8220;This pandemic must become a wake-up call that drives us to work at every level of society to change the structures that allow these inequities to persist,&#8221; she said in a statement. &#8220;We are encouraging all Catholic sisters to participate in this act of prayer and solidarity.&#8221;</p>



<p>The faith leaders also asked that at noon local time June 1, &#8220;the country pause once more to remember those who have died.&#8221;</p>



<p>The June 1 observance is being supported by the U.S. Conference of Mayors, which represents more than 1,400 mayors across the country, LCWR said.</p>



<p>In the United States, the death toll from COVID had reached 102,391, as of May 28.</p>



<p>President Donald Trump said the U.S. had reached a &#8220;very sad milestone&#8221; in exceeding 100,000 deaths and tweeted: &#8220;To all of the families and friends of those who have passed, I want to extend my heartfelt sympathy and love for everything that these great people stood for and represent. God be with you!&#8221;</p>



<p>Earlier he had ordered flags on federal buildings and national monuments to be flown at half-staff May 22-25 &#8220;in memory of the Americans we have lost to the coronavirus.&#8221;</p>
                </section> 
                <footer class="article-footer">

                  filed under: <a href="https://thefloridacatholic.org/category/national-and-international/" rel="category tag">National and International</a>
                  <p class="tags"><span class="tags-title">Tags:</span> <a href="https://thefloridacatholic.org/tag/covid19/" rel="tag">covid19</a>, <a href="https://thefloridacatholic.org/tag/faith-leaders/" rel="tag">faith leaders</a></p>
                </footer> 
                
              </article> 
						
						
             
                    
							   
							   
							   
							   

<!--<p>ADVERTISEMENT</p>-->

  
<div class="cf"></div>
 <div class="flc-mobile-ad m-all">
   <a href="https://franciscanmissionassoc.org/prayer-requests/devotional-saints/st-anthony/?utm_campaign=amps-fma-webad" target="_blank"> <img src="https://thefloridacatholic.org/wp-content/uploads/2020/05/web_popup2-1.jpg" /></a>
</div>
 <div class="cf"></div>

 



							</article>

						</main>
                        
                   </div>

						
	 				
                <!--
                <div id="sidebar1" class="sidebar m-all t-1of3 d-2of7 last-col cf" role="complementary">

					
						
					
						
						<div class="no-widgets">
							<p></p>
						</div>

					
				</div>
                -->


	<div id="flc-sidebar">
                        
                        	<div id="flc-side-featured">

                            									
								<a href="https://secure.givelively.org/donate/florida-catholic-inc/long-sleeve-relief" target="_blank"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/lsr_web-icon.png" /><br/>Donate<br /> Today</a>
								
								<a href="/newsletter/"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/flc-banner-newsletter.png" /><br/>Monthly Newsletter</a>
								
								<a href="http://digital.thefloridacatholic.org/" target="_blank"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/e-edtion-free-icon.png" /><br />Get Our<br />e-Edition</a>
								
								
								
								
								
								<a href="/advertising/"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/flc-banner-links4.png" />Advertise<br />with us</a>
								
								<a href="/address-change/"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/flc-banner-links1.png" /><br/>Address<br /> Change</a>
								
								
								
								<a href="/subscribe/"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/flc-banner-links3.png" /><br/>Subscribe<br />or Renew</a>
                                
                               
                                   
                                   <div class="cf"></div>
                                   
                            
                            
                            </div>						

							
                            <div id="flc-side-ads">
							
							<br><br>
							<center>
							<a href="http://digital.thefloridacatholic.org">
								<img src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/FLC-E-edition-03-2020-300x300.jpg" alt="Please click here to access our FREE e-edition" />
							</a>
							</center>
							
							                            
                            <p>ADVERTISEMENT</p>
															 <div class="flc-right-ad">
   <a href="https://franciscanmissionassoc.org/prayer-requests/devotional-saints/st-anthony/?utm_campaign=amps-fma-webad" target="_blank"> <img src="https://thefloridacatholic.org/wp-content/uploads/2020/05/web_popup2-1.jpg" /></a>
</div> 															                              
                            </div>
						</div>                        
                        <div class="cf"></div>
				</div>

			</div>

﻿            <div id="flc-footer-esignup" >                        	<div class="wrap cf">                	                    <h3>Sign-up for our <a href="https://sibforms.com/serve/MUIEACaFbkeELTUu0f-TatsdUeZb9e85s3YMmPcLRlxbop8AOfbw_aOxSBm_UXF9hg0DD1QUfxo7vDsEdSs8VDN45KFMttVURqnx-9dByd4jkq28X63oZhOA_mNawoIx3EWWxFXK_eSXNEAwtaJZlQMyB2vborhB-WD4K5wEkLzHbRDPo0jOCaxBh_BCiNtHg9i9wSxtpaMqyiJg" target="_blank">Newsletter</a></h3><p>Enter your email to be a part of our mailing list. Don’t worry, we don’t share them!</p>                    <a href="https://sibforms.com/serve/MUIEACaFbkeELTUu0f-TatsdUeZb9e85s3YMmPcLRlxbop8AOfbw_aOxSBm_UXF9hg0DD1QUfxo7vDsEdSs8VDN45KFMttVURqnx-9dByd4jkq28X63oZhOA_mNawoIx3EWWxFXK_eSXNEAwtaJZlQMyB2vborhB-WD4K5wEkLzHbRDPo0jOCaxBh_BCiNtHg9i9wSxtpaMqyiJg" class="flc-footer-esignup-btn" target="_blank">Join our list!</a><br />                                    </div>                                                                                             </div>  			            <div id="flc-footer-ways2sub">               	                <div class="wrap cf">                               <h3>Ways to <a href="https://thefloridacatholic.org/subscribe/">Subscribe</a></h3>                              </div>                              <div class="wrap cf">                                                	<div class="m-all t-1of3 d-1of3 ">                                        <a href="https://thefloridacatholic.org/subscribe/ "><img src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/flc-footer-laptop.jpg" /></a>                <h4>Option 1</h4>                                <p>Fill out the online subscription form <a href="https://thefloridacatholic.org/subscribe/ ">here!</a><br />Or call toll-free 1-888-275-9953</p>						</div>					<div class="m-all t-1of3 d-1of3">                                        <img src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/flc-footer-letter.jpg" /></a>					<h4>Option 2</h4>                                                            Send a check payable to: <strong>Florida Catholic</strong><br />PO Box 4993, Orlando, FL 32802-4993					</div>					<div class="m-all t-1of3 d-1of3">					<a href="https://digital.thefloridacatholic.org/"><img src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/images/flc-footer-tablet.jpg" /></a>					<h4>Option 3</h4><p>Subscribe to our <strong>e-Edition</strong> and enjoy<br />Catholic news on any browser.</p>					</div>                                </div>                                    </div>                                                             	<footer class="footer" role="contentinfo" itemscope itemtype="http://schema.org/WPFooter">				<div id="inner-footer" class="wrap cf">					<nav role="navigation">											</nav>					<p class="source-org copyright">&copy; 2020 Florida Catholic. All rights reserved. <a href="https://thefloridacatholic.org/classifieds/" target="_blank">Classifieds</a> | <a href="https://thefloridacatholic.org/privacy-statement/">Privacy</a>                                        <div class="flc-connect">                    	Connect with us                    	<ul>                    		<li><a href="http://www.facebook.com/FloridaCatholic/" target="_blank"><i class="fa fa-facebook"></i></a></li>                            <li><a href="https://twitter.com/floridacatholic" target="_blank"><i class="fa fa-twitter"></i></a></li>                            <li><a href="https://thefloridacatholic.org/feed/" target="_blank"><i class="fa fa-rss"></i></a></li>                                                	</ul>                    </div>				</div>			</footer>		</div>				<div id="pum-16653" class="pum pum-overlay pum-theme-16647 pum-theme-default-theme popmake-overlay auto_open click_open" data-popmake="{&quot;id&quot;:16653,&quot;slug&quot;:&quot;sign-up-form&quot;,&quot;theme_id&quot;:16647,&quot;cookies&quot;:[],&quot;triggers&quot;:[{&quot;type&quot;:&quot;auto_open&quot;,&quot;settings&quot;:{&quot;cookie_name&quot;:&quot;&quot;,&quot;delay&quot;:&quot;500&quot;}},{&quot;type&quot;:&quot;click_open&quot;,&quot;settings&quot;:{&quot;extra_selectors&quot;:&quot;&quot;,&quot;cookie_name&quot;:null}}],&quot;mobile_disabled&quot;:null,&quot;tablet_disabled&quot;:null,&quot;meta&quot;:{&quot;display&quot;:{&quot;stackable&quot;:false,&quot;overlay_disabled&quot;:false,&quot;scrollable_content&quot;:false,&quot;disable_reposition&quot;:false,&quot;size&quot;:&quot;small&quot;,&quot;responsive_min_width&quot;:&quot;40%&quot;,&quot;responsive_min_width_unit&quot;:false,&quot;responsive_max_width&quot;:&quot;90%&quot;,&quot;responsive_max_width_unit&quot;:false,&quot;custom_width&quot;:&quot;90%&quot;,&quot;custom_width_unit&quot;:false,&quot;custom_height&quot;:&quot;800px&quot;,&quot;custom_height_unit&quot;:false,&quot;custom_height_auto&quot;:&quot;1&quot;,&quot;location&quot;:&quot;center&quot;,&quot;position_from_trigger&quot;:false,&quot;position_top&quot;:&quot;100&quot;,&quot;position_left&quot;:&quot;0&quot;,&quot;position_bottom&quot;:&quot;0&quot;,&quot;position_right&quot;:&quot;0&quot;,&quot;position_fixed&quot;:false,&quot;animation_type&quot;:&quot;fade&quot;,&quot;animation_speed&quot;:&quot;350&quot;,&quot;animation_origin&quot;:&quot;center top&quot;,&quot;overlay_zindex&quot;:false,&quot;zindex&quot;:&quot;1999999999&quot;},&quot;close&quot;:{&quot;text&quot;:&quot;&quot;,&quot;button_delay&quot;:&quot;0&quot;,&quot;overlay_click&quot;:false,&quot;esc_press&quot;:false,&quot;f4_press&quot;:false},&quot;click_open&quot;:[]}}" role="dialog" aria-hidden="true" >

	<div id="popmake-16653" class="pum-container popmake theme-16647 pum-responsive pum-responsive-small responsive size-small">

				

				

		

				<div class="pum-content popmake-content">
			<p><iframe width="100%" height="650" src="https://642d0439.sibforms.com/serve/MUIEADiZqpuzuew8VuqG_hSnBe43_fTFxKMXgCitFbOQfKg5Ikd98i2-KYe0W0g2CmuDFuIhmvIpjj9xgjzPTS1hJd9im522qKE5dr52I_17BnrwZRsXDH_zd5Va_qPp9XTP_nq8v98jb9xe03nilwmnxuY7pr9t71lrKPAl9vqflV2PXQrdl_M3ZnJudcgy7kUVsYznY9JEd39K" frameborder="0" scrolling="auto" allowfullscreen style="display: block;margin-left: auto;margin-right: auto;max-width: 100%;"></iframe></p>
		</div>


				

				            <button type="button" class="pum-close popmake-close" aria-label="Close">
			CLOSE            </button>
		
	</div>

</div>
	<script type="text/javascript">
		var c = document.body.className;
		c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
		document.body.className = c;
	</script>
	<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/thefloridacatholic.org\/cart\/","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_b05d898529292be3606b27810efe78ca","fragment_name":"wc_fragments_b05d898529292be3606b27810efe78ca","request_timeout":"5000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/woocommerce/assets/js/jquery-payment/jquery.payment.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sv_wc_payment_gateway_payment_form_params = {"card_number_missing":"Card number is missing","card_number_invalid":"Card number is invalid","card_number_digits_invalid":"Card number is invalid (only digits allowed)","card_number_length_invalid":"Card number is invalid (wrong length)","cvv_missing":"Card security code is missing","cvv_digits_invalid":"Card security code is invalid (only digits are allowed)","cvv_length_invalid":"Card security code is invalid (must be 3 or 4 digits)","card_exp_date_invalid":"Card expiration date is invalid","check_number_digits_invalid":"Check Number is invalid (only digits are allowed)","check_number_missing":"Check Number is missing","drivers_license_state_missing":"Drivers license state is missing","drivers_license_number_missing":"Drivers license number is missing","drivers_license_number_invalid":"Drivers license number is invalid","account_number_missing":"Account Number is missing","account_number_invalid":"Account Number is invalid (only digits are allowed)","account_number_length_invalid":"Account number is invalid (must be between 5 and 17 digits)","routing_number_missing":"Routing Number is missing","routing_number_digits_invalid":"Routing Number is invalid (only digits are allowed)","routing_number_length_invalid":"Routing number is invalid (must be 9 digits)"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/woocommerce-gateway-authorize-net-cim/vendor/skyverge/wc-plugin-framework/woocommerce/payment-gateway/assets/js/frontend/sv-wc-payment-gateway-payment-form.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/woocommerce-gateway-authorize-net-cim/assets/js/frontend/wc-authorize-net-cim.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-includes/js/jquery/ui/position.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pum_vars = {"version":"1.10.1","pm_dir_url":"https:\/\/thefloridacatholic.org\/wp-content\/plugins\/popup-maker\/","ajaxurl":"https:\/\/thefloridacatholic.org\/wp-admin\/admin-ajax.php","restapi":"https:\/\/thefloridacatholic.org\/wp-json\/pum\/v1","rest_nonce":null,"default_theme":"16647","debug_mode":"","disable_tracking":"","home_url":"\/","message_position":"top","core_sub_forms_enabled":"1","popups":[]};
var ajaxurl = "https:\/\/thefloridacatholic.org\/wp-admin\/admin-ajax.php";
var pum_sub_vars = {"ajaxurl":"https:\/\/thefloridacatholic.org\/wp-admin\/admin-ajax.php","message_position":"top"};
var pum_popups = {"pum-16653":{"disable_on_mobile":false,"disable_on_tablet":false,"custom_height_auto":true,"scrollable_content":false,"position_from_trigger":false,"position_fixed":false,"overlay_disabled":false,"stackable":false,"disable_reposition":false,"close_on_form_submission":false,"close_on_overlay_click":false,"close_on_esc_press":false,"close_on_f4_press":false,"disable_form_reopen":false,"disable_accessibility":false,"triggers":[{"type":"auto_open","settings":{"cookie_name":"","delay":"500"}}],"theme_id":"16647","size":"small","responsive_min_width":"40%","responsive_max_width":"90%","custom_width":"90%","custom_height":"800px","animation_type":"fade","animation_speed":"350","animation_origin":"center top","open_sound":"none","custom_sound":"","location":"center","position_top":"100","position_bottom":"0","position_left":"0","position_right":"0","zindex":"1999999999","close_button_delay":"0","close_on_form_submission_delay":"0","cookies":[],"theme_slug":"default-theme","id":16653,"slug":"sign-up-form"}};
/* ]]> */
</script>
<script type='text/javascript' src='//thefloridacatholic.org/wp-content/uploads/pum/pum-site-scripts.js?defer&#038;generated=1590111641'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/js/scripts.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-includes/js/wp-embed.min.js'></script>
	<script src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2018/library/js/storepage.js"></script>			</body></html> <!-- end of site. what a ride! -->