<!doctype html>

<!--[if lt IE 7]><html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js lt-ie9 lt-ie8 lt-ie7"><![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js"><!--<![endif]-->

	<head>
		<meta charset="utf-8">

				<meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[f.now()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,t){s[t]=o(d+t,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),t.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(l+"tracer",[f.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[f.now(),r,o],n),o)try{return t.apply(this,arguments)}catch(e){throw c.emit("fn-err",[arguments,this,e],n),e}finally{c.emit("fn-end",[f.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){m[t]=o(l+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,f.now()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],4:[function(e,t,n){t.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o,i){if(!d.aborted||i){e&&e(n,r,o);for(var a=t(o),u=m(n),c=u.length,f=0;f<c;f++)u[f].apply(a,r);var p=s[y[n]];return p&&p.push([b,n,r,a]),a}}function l(e,t){v[e]=m(e).concat(t)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(n)}function g(e,t){f(e,function(e,n){t=t||"feature",y[n]=t,t in s||(s[t]=[])})}var v={},y={},b={on:l,emit:n,get:w,listeners:m,context:t,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},p={},d=t.exports=o();d.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!x++){var e=h.info=NREUM.info,t=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return s.abort();f(y,function(t,n){e[t]||(e[t]=n)}),c("mark",["onload",a()+h.offset],null,"api");var n=d.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===d.readyState&&i()}function i(){c("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),c=e("handle"),f=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1071.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=t.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),c("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>

		<title>Priest’s lunch ministry reaches downtown residents - Florida Catholic</title>

				<meta name="HandheldFriendly" content="True">
		<meta name="MobileOptimized" content="320">
		<meta name="viewport" content="width=device-width, initial-scale=1"/>
                
        
		
<script src="https://ajax.googleapis.com/ajax/libs/webfont/1.6.16/webfont.js"></script>
<script>
  WebFont.load({
    google: {
      families: ['Montserrat']
    }
  });
</script>
        
        
        		
		<link rel="stylesheet" href="https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/font-awesome-4.4.0/css/font-awesome.min.css">
        

				<link rel="apple-touch-icon" href="https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/images/apple-touch-icon.png">
		<link rel="icon" href="https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/favicon.png">
		<!--[if IE]>
			<link rel="shortcut icon" href="https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/favicon.ico">
		<![endif]-->
        
        
        
        
				<meta name="msapplication-TileColor" content="#f01d4f">
		<meta name="msapplication-TileImage" content="https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/images/win8-tile-icon.png">
            <meta name="theme-color" content="#121212">

		<link rel="pingback" href="https://thefloridacatholic.org/xmlrpc.php">

				
<!-- This site is optimized with the Yoast SEO plugin v6.3.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://thefloridacatholic.org/2018/03/29/priests-lunch-ministry-reaches-downtown-residents/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Priest’s lunch ministry reaches downtown residents - Florida Catholic" />
<meta property="og:description" content="ORLANDO | It’s a sunny day around noon, and you can find Father Chris Dorsey, parochial vicar at St. James Cathedral in Orlando, a few blocks from his parish, sitting on a bench overlooking Lake Eola. He’s not just taking in the warm Florida sunshine. He’s hoping someone will notice his sign: “Catholic Priest: Prayer,...  Read more &raquo;" />
<meta property="og:url" content="https://thefloridacatholic.org/2018/03/29/priests-lunch-ministry-reaches-downtown-residents/" />
<meta property="og:site_name" content="Florida Catholic" />
<meta property="article:tag" content="Father Chris Dorsey" />
<meta property="article:tag" content="lunch ministry" />
<meta property="article:tag" content="St. James Orlando" />
<meta property="article:section" content="Orlando" />
<meta property="article:published_time" content="2018-03-29T19:55:54+00:00" />
<meta property="article:modified_time" content="2018-04-04T15:40:06+00:00" />
<meta property="og:updated_time" content="2018-04-04T15:40:06+00:00" />
<meta property="og:image" content="https://thefloridacatholic.org/wp-content/uploads/2018/03/bench.jpg" />
<meta property="og:image:secure_url" content="https://thefloridacatholic.org/wp-content/uploads/2018/03/bench.jpg" />
<meta property="og:image:width" content="883" />
<meta property="og:image:height" content="385" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="ORLANDO | It’s a sunny day around noon, and you can find Father Chris Dorsey, parochial vicar at St. James Cathedral in Orlando, a few blocks from his parish, sitting on a bench overlooking Lake Eola. He’s not just taking in the warm Florida sunshine. He’s hoping someone will notice his sign: “Catholic Priest: Prayer,...  Read more &raquo;" />
<meta name="twitter:title" content="Priest’s lunch ministry reaches downtown residents - Florida Catholic" />
<meta name="twitter:image" content="https://thefloridacatholic.org/wp-content/uploads/2018/03/bench.jpg" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/thefloridacatholic.org\/","name":"Florida Catholic","potentialAction":{"@type":"SearchAction","target":"https:\/\/thefloridacatholic.org\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Florida Catholic &raquo; Feed" href="https://thefloridacatholic.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Florida Catholic &raquo; Comments Feed" href="https://thefloridacatholic.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Florida Catholic &raquo; Priest’s lunch ministry reaches downtown residents Comments Feed" href="https://thefloridacatholic.org/2018/03/29/priests-lunch-ministry-reaches-downtown-residents/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thefloridacatholic.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='rs-plugin-settings-css'  href='https://thefloridacatholic.org/wp-content/plugins/revslider/public/assets/css/settings.css' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Lato%3A400%2C700%2C400italic%2C700italic' type='text/css' media='all' />
<link rel='stylesheet' id='bones-stylesheet-css'  href='https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/css/style.css' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='bones-ie-only-css'  href='https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/css/ie.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='checkout-bootstrap-css'  href='https://thefloridacatholic.org/wp-content/plugins/wp-checkout/views/flc-bootstrap/css/bootstrap.css' type='text/css' media='all' />
<link rel='stylesheet' id='touchspin-css'  href='https://thefloridacatholic.org/wp-content/plugins/wp-checkout/views/flc-bootstrap/css/jquery.bootstrap-touchspin.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-lightbox-css'  href='//cdnjs.cloudflare.com/ajax/libs/ekko-lightbox/4.0.1/ekko-lightbox.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-slider-css'  href='//cdnjs.cloudflare.com/ajax/libs/bootstrap-slider/4.10.0/css/bootstrap-slider.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.3.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='select2-css'  href='//cdnjs.cloudflare.com/ajax/libs/select2/4.0.0/css/select2.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-datepicker-css'  href='//cdnjs.cloudflare.com/ajax/libs/bootstrap-datepicker/1.4.1/css/bootstrap-datepicker.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='uploadify-css'  href='https://thefloridacatholic.org/wp-content/plugins/wp-checkout/views/flc-bootstrap/css/ajaxupload.css' type='text/css' media='all' />
<link rel='stylesheet' id='checkout-css'  href='https://thefloridacatholic.org/wp-content/plugins/wp-checkout/views/flc-bootstrap/style.css' type='text/css' media='all' />
<script type='text/javascript' src='https://thefloridacatholic.org/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/js/libs/modernizr.custom.min.js'></script>
<script type='text/javascript' src='//maxcdn.bootstrapcdn.com/bootstrap/3.3.4/js/bootstrap.min.js'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/bootstrap-datepicker/1.4.1/js/bootstrap-datepicker.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bootstrap_datepicker_dates = {"days":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"daysShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"daysMin":["S","M","T","W","T","F","S"],"months":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthsShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"today":"Today","clear":"Clear","rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/wp-checkout/views/flc-bootstrap/js/datepicker-i18n.js'></script>
<link rel='https://api.w.org/' href='https://thefloridacatholic.org/wp-json/' />
<link rel='shortlink' href='https://thefloridacatholic.org/?p=3647' />
<link rel="alternate" type="application/json+oembed" href="https://thefloridacatholic.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthefloridacatholic.org%2F2018%2F03%2F29%2Fpriests-lunch-ministry-reaches-downtown-residents%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thefloridacatholic.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthefloridacatholic.org%2F2018%2F03%2F29%2Fpriests-lunch-ministry-reaches-downtown-residents%2F&#038;format=xml" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//thefloridacatholic.org/?wordfence_lh=1&hid=93E98282C73D7F96140C338CD16E5818');
</script><!--[if lt IE 8]>
<style type="text/css">
div.productsgrid ul li {
    display: inline;
    zoom: 1;
}

div.wpcocategoriesgrid ul li {
    display: inline;
    zoom: 1;
    width: 300px;
}
</style>
<![endif]-->

<!--[if lt IE 10]>
<style type="text/css">
.checkout_loading {
	width: 16px;
	height: 16px;
	background: transparent url('https://thefloridacatholic.org/wp-content/plugins/wp-checkout/views/flc-bootstrap/img/loading.gif') no-repeat;
	display: inline-block;
}
</style>
<![endif]-->

<!-- HTML5 shim and Respond.js for IE8 support of HTML5 elements and media queries -->
<!-- WARNING: Respond.js doesn't work if you view the page via file:// -->
<!--[if lt IE 9]>
  <script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
  <script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
<![endif]-->


<script type="text/javascript">
var wpcoURL = "https://thefloridacatholic.org/wp-content/plugins/wp-checkout";
var wpcoAjax = "https://thefloridacatholic.org/wp-content/plugins/wp-checkout/wp-checkout-ajax.php";
var checkout_ajaxurl = "https://thefloridacatholic.org/wp-admin/admin-ajax.php?";
var wpcoCurrency = "&#36;";
var checkout_favorites_url = "https://thefloridacatholic.org/shop/your-account/?wpcomethod=favorites";
var cart_frontend_notice = true;

jQuery(document).ready(function() {
	if (jQuery.isFunction(jQuery.fn.tooltip)) {
		jQuery(".wpcohelp a").tooltip();
	}
	
	if (jQuery.isFunction(jQuery.fn.select2)) {
		jQuery('select.checkout_country, select.checkout_states, select.checkout_select2').select2({
			dropdownAutoWidth: true
		});
	}
	
	jQuery('.checkout .spinner').TouchSpin({
		max: 999999,
		verticalbuttons: true,
		verticalupclass: 'fa fa-caret-up fa-fw',
		verticaldownclass: 'fa fa-caret-down fa-fw',
	}).on('touchspin.on.stopspin', function(touchspinner) {		
		var product_id = jQuery(this).data('product-id');
		if (typeof product_id != 'undefined') {
			checkout_product_update_price(product_id);
		}
	});
	
	jQuery('.checkout_lightbox').on('click', function(e) {  
		jQuery(this).ekkoLightbox({
			left_arrow_class: '.fa .fa-chevron-left .text-left',
			right_arrow_class: '.fa .fa-chevron-right .text-right',
		});
		
		e.preventDefault();
	});
});
</script>            
            <script type="text/javascript">
            jQuery(document).ready(function() {
				if (jQuery.isFunction(jQuery.fn.colorbox)) { jQuery('.colorbox').colorbox({maxWidth:'100%', maxHeight:'90%'}); }
				
				
				if (jQuery.isFunction(jQuery.fn.button)) { jQuery('.productsubmit input, .wpcobutton').button(); }
				if (jQuery.isFunction(jQuery.fn.ddslick)) { jQuery('.ddslick').ddslick(); }
			});
            
            				var wpcoajaxurl = "https://thefloridacatholic.org/wp-admin/admin-ajax.php?";
						var wpcoDoAjax = false;
			var wpcoScrollAjax = true;
			
						</script>
            
            <meta name="generator" content="Powered by Slider Revolution 5.4.6 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
<script type="text/javascript">function setREVStartSize(e){
				try{ var i=jQuery(window).width(),t=9999,r=0,n=0,l=0,f=0,s=0,h=0;					
					if(e.responsiveLevels&&(jQuery.each(e.responsiveLevels,function(e,f){f>i&&(t=r=f,l=e),i>f&&f>r&&(r=f,n=e)}),t>r&&(l=n)),f=e.gridheight[l]||e.gridheight[0]||e.gridheight,s=e.gridwidth[l]||e.gridwidth[0]||e.gridwidth,h=i/s,h=h>1?1:h,f=Math.round(h*f),"fullscreen"==e.sliderLayout){var u=(e.c.width(),jQuery(window).height());if(void 0!=e.fullScreenOffsetContainer){var c=e.fullScreenOffsetContainer.split(",");if (c) jQuery.each(c,function(e,i){u=jQuery(i).length>0?u-jQuery(i).outerHeight(!0):u}),e.fullScreenOffset.split("%").length>1&&void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0?u-=jQuery(window).height()*parseInt(e.fullScreenOffset,0)/100:void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0&&(u-=parseInt(e.fullScreenOffset,0))}f=u}else void 0!=e.minHeight&&f<e.minHeight&&(f=e.minHeight);e.c.closest(".rev_slider_wrapper").css({height:f})					
				}catch(d){console.log("Failure at Presize of Slider:"+d)}
			};</script>
		
				
		<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-82857878-1', 'auto');
  ga('send', 'pageview');

</script>
		
	</head>

	<body class="post-template-default single single-post postid-3647 single-format-standard" itemscope itemtype="http://schema.org/WebPage">

		<div id="container">

			<header class="header" role="banner" itemscope itemtype="http://schema.org/WPHeader">
            
								<div class="flc-mob-menu">

					<input type="checkbox" id="flc-mob-trigger">
        				<label class="flc-nav-btn" for="flc-mob-trigger"><span></span></label>

					
						<ul id="menu-main-nav" class="flc-mob-nav cf"><li id="menu-item-44" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-44"><a href="https://thefloridacatholic.org/">Home</a></li>
<li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30"><a href="https://thefloridacatholic.org/sunday-word/">Sunday Word</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29"><a href="https://thefloridacatholic.org/florida-bishops/">Florida Bishops</a></li>
<li id="menu-item-2122" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2122"><a href="https://thefloridacatholic.org/local-diocese/">Local Diocese</a></li>
<li id="menu-item-27" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27"><a href="https://thefloridacatholic.org/article-request/">Article Request</a></li>
<li id="menu-item-26" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26"><a href="https://thefloridacatholic.org/give-feedback/">Give Feedback</a></li>
<li id="menu-item-25" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25"><a href="https://thefloridacatholic.org/about-us/">About Us</a></li>
<li id="menu-item-2106" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2106"><a href="https://thefloridacatholic.org/classifieds/">Classifieds</a></li>
</ul>
					

				</div>

						
			
            <div id="flc-top" class="wrap cf">
            
				<div class="flc-header-logo m-all t-305 d-4of5">
				<a href="https://thefloridacatholic.org" rel="nofollow">                    
                    <img width="55%" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/images/flc_logo.svg" /></a>
                </div>
                    
                 <div class="flc-header-right m-all t-205 d-1of5">
                    
                  <div id="flc-search">
                      <form role="search" method="get" id="searchform" class="searchform" action="https://thefloridacatholic.org/">
    <div>
        <label for="s" class="screen-reader-text">Search for:</label>
        <input type="search" id="s" name="s" value="" />

        <button type="submit" id="searchsubmit" >Search</button>
    </div>
</form>                    </div>
                    <i class="fa fa-phone flc-head-blue"></i> 407-373-0075 <span class="flc-head-blue">|</span> 888-275-9953 <br />
                    
                    <div class="flc-head-connect">
                    	Connect with us
                    	<ul>
                    		<li><a href="http://www.facebook.com/FloridaCatholic/" target="_blank"><i class="fa fa-facebook"></i></a></li>
                            <li><a href="https://twitter.com/floridacatholic" target="_blank"><i class="fa fa-twitter"></i></a></li>
                            <li><a href="https://thefloridacatholic.org/feed/" target="_blank"><i class="fa fa-rss"></i></a></li>
                    	</ul>

                     </div>
                        
                    </div>
                    
 
             </div>
             
             <div class="flc-navigation">

				<div id="inner-header" class="wrap cf">

		


					<nav role="navigation" itemscope itemtype="http://schema.org/SiteNavigationElement">
						<ul id="menu-main-nav-1" class="nav top-nav cf"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-44"><a href="https://thefloridacatholic.org/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30"><a href="https://thefloridacatholic.org/sunday-word/">Sunday Word</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29"><a href="https://thefloridacatholic.org/florida-bishops/">Florida Bishops</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2122"><a href="https://thefloridacatholic.org/local-diocese/">Local Diocese</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27"><a href="https://thefloridacatholic.org/article-request/">Article Request</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26"><a href="https://thefloridacatholic.org/give-feedback/">Give Feedback</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25"><a href="https://thefloridacatholic.org/about-us/">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2106"><a href="https://thefloridacatholic.org/classifieds/">Classifieds</a></li>
</ul>						
					</nav>

				</div>
                
                </div>

			</header>

			<div id="content">
			<div id="inner-content" class="wrap cf">

			<div id="flc-body">
  

					<main id="main" class="m-all t-all d-all cf" role="main" itemscope itemprop="mainContentOfPage" itemtype="http://schema.org/Blog">

						
							
              
              <article id="post-3647" class="cf post-3647 post type-post status-publish format-standard has-post-thumbnail hentry category-orlando tag-father-chris-dorsey tag-lunch-ministry tag-st-james-orlando" role="article" itemscope itemprop="blogPost" itemtype="http://schema.org/BlogPosting">
			  
			  <div class="flc-hp-topfeatimage">
			   <img width="883" height="385" src="https://thefloridacatholic.org/wp-content/cache/thumbnails/2018/03/bench-883x385-c.jpg" class="attachment-883x385x1 size-883x385x1 wp-post-image" alt="" />						 <p style="padding-left:24px; color:#8d8d8d;"><em>Three times a week, Father Chris Dorsey sits overlooking Lake Eola, inviting passersby to pray with him, receive confession and just to chat. On this day he obliged someone asking him to sign a fair wage petition, anything to engage others on the subject of God. (GLENDA MEEKINS | FC)</em></p> 
										</div>
                <header class="article-header entry-header">

                  <h1 class="entry-title single-title" itemprop="headline" rel="bookmark">Priest’s lunch ministry reaches downtown residents</h1>

                   <p class="flc-blog-byline">By GLENDA MEEKINS of the Florida Catholic staff | March 29, 2018</p>

                </header> 
                <section class="entry-content cf" itemprop="articleBody">
                  <p><strong>ORLANDO</strong> | It’s a sunny day around noon, and you can find Father Chris Dorsey, parochial vicar at St. James Cathedral in Orlando, a few blocks from his parish, sitting on a bench overlooking Lake Eola.<br />
He’s not just taking in the warm Florida sunshine. He’s hoping someone will notice his sign: “Catholic Priest: Prayer, Confession, Conversation.” The idea was inspired by previous seminarian classmates who later served as college campus ministers.</p>
<p>“The downtown park is the middle of everything, so I thought I would see what happens,” he said. “(W)hat I’ve realized is the change that occurs when people see me. A lot of times you’ll hear the conversation change. I think it’s a good witness to the faith and even if people don’t stop to sit down and talk, it changes something about the conversation and about their day just to see me there.”</p>
<p>Father Dorsey began the practice as a Lenten offering, but said he plans to continue beyond that. He can be found there three days a week, either at lunch time or in the evening after people have returned home from work and are out for a stroll. He said many times people ask to take his picture. Recently, a parishioner shared the photo on Facebook and Instagram, launching him to the No. 1 spot for Catholic priests on Instagram.</p>
<p>“To me, that shows there’s a hunger to see more priests in public and that it’s not seen enough. I hope it inspires other priests,” he said, adding that priests’ lives are public. “The temptation is to pop the collar out when we’re out in public and go incognito. And this is full ministry mode. It is not relaxing, doing nothing. But the gains from it, even if it’s just a change in conversation or the hope and pride in the Catholic faith that I give somebody, it’s worth it.”</p>
<p>Father Dorsey said he has yet to have someone come for confession, although some have suggested their friends should. It is more counseling and sharing their own stories, including his.<br />
“In the Church, we sometimes get caught up in being sacramental vending machines,” he acknowledged. “We do Mass, Adoration, Confession. But God calls us to be more, to evangelize. It’s good for my heart to live out that part of the Gospel.”</p>
                </section> 
                <footer class="article-footer">

                  filed under: <a href="https://thefloridacatholic.org/category/orlando/" rel="category tag">Orlando</a>
                  <p class="tags"><span class="tags-title">Tags:</span> <a href="https://thefloridacatholic.org/tag/father-chris-dorsey/" rel="tag">Father Chris Dorsey</a>, <a href="https://thefloridacatholic.org/tag/lunch-ministry/" rel="tag">lunch ministry</a>, <a href="https://thefloridacatholic.org/tag/st-james-orlando/" rel="tag">St. James Orlando</a></p>
                </footer> 
                
              </article> 
						
						
             
                    
							   
							   
							   
							   
<footer class="article-footer cf">
<p>ADVERTISEMENT</p>

 <div class="flc-footer-ad">
   <a href="http://www.DisneyOnIce.com/" target="_blank"> <img src="https://thefloridacatholic.org/wp-content/uploads/2018/03/web-ad-for-ORL-Dare-To-Dream-May-show.gif" /></a>
</div> 
<div class="cf"></div>
 
 <div class="flc-mobile-ad m-all">
   <a href="http://www.cambridgehealth.edu/" target="_blank"> <img src="https://thefloridacatholic.org/wp-content/uploads/2017/04/cambridge_web.jpg" /></a>
</div><div class="cf"></div>

</footer> 



							</article>

						</main>
                        
                   </div>

						
	 				
                <!--
                <div id="sidebar1" class="sidebar m-all t-1of3 d-2of7 last-col cf" role="complementary">

					
						
					
						
						<div class="no-widgets">
							<p></p>
						</div>

					
				</div>
                -->


	<div id="flc-sidebar">
                        
                        	<div id="flc-side-featured">

                            									
								<a href="/request-a-prayer/"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/images/flc-banner-links2.png" /><br/>Prayer<br /> Request</a>
								
								<a href="/subscribe/"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/images/flc-banner-links3.png" /><br/>Subscribe<br />or Renew</a>
								
								<a href="/newsletter/"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/images/flc-banner-newsletter.png" /><br/>Monthly Newsletter</a>
								
								
								
								<a href="/advertising/"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/images/flc-banner-links4.png" />Advertise<br />with us</a>
								
								<a href="/address-change/"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/images/flc-banner-links1.png" /><br/>Address<br /> Change</a>
								
								<a href="http://digital.thefloridacatholic.org/sub/account_login.php"><img class="flc-featured-thumb" src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/images/flc-banner-ipad.png" /><br />Get Our<br />e-Edition</a>
                                
                               
                                   
                                   <div class="cf"></div>
                                   
                            
                            
                            </div>							<center>
							<br />
							<br />
							<iframe src="https://www.youcaring.com/fundraiser-widget.aspx?frid=1078575" width="260" height="398" frameborder="0"></iframe>
							<br />
							<br />
							
                            </center>
							
                            <div id="flc-side-ads">
                            
                            <p>ADVERTISEMENT</p>
															  															 <div class="flc-right-ad">
   <a href="https://thefloridacatholic.org/subscribe/" target="_blank"> <img src="https://thefloridacatholic.org/wp-content/uploads/2016/02/subscribe.jpg" /></a>
</div><div class="flc-right-ad">
   <a href="http://www.gannon.edu/" target="_blank"> <img src="https://thefloridacatholic.org/wp-content/uploads/2017/12/Gannon-Ruskin-web-ad.jpg" /></a>
</div><div class="flc-right-ad">
   <a href="https://www.annuitysvd.org/" target="_blank"> <img src="https://thefloridacatholic.org/wp-content/uploads/2017/10/SOTDW_201711-201712-1.jpg" /></a>
</div><div class="flc-right-ad">
   <a href="http://www.cambridgehealth.edu/" target="_blank"> <img src="https://thefloridacatholic.org/wp-content/uploads/2017/04/cambridge_web.jpg" /></a>
</div>                             
                            </div>
						</div>                        
                        <div class="cf"></div>

				</div>

			</div>

﻿            <div id="flc-footer-esignup" >
            
            	<div class="wrap cf">
                	
                    <h3>Sign-up for our <a href="https://my.sendinblue.com/users/subscribe/js_id/2dvef/id/1">Newsletter</a></h3><p>Enter your email to be a part of our mailing list. Don’t worry, we don’t share them!</p>
                    


<a href="https://my.sendinblue.com/users/subscribe/js_id/2dvef/id/1" class="flc-footer-esignup-btn" target="_blank">Join our list!</a><br />
                    
                </div>
                
            
            
                
             
            
            </div>  

			
            <div id="flc-footer-ways2sub">   
            	
                <div class="wrap cf">
                
               <h3>Ways to <a href="https://thefloridacatholic.org/florida-catholic-subscription/">Subscribe</a></h3>
               
               </div>
               
               <div class="wrap cf">
                
                
                	<div class="m-all t-1of3 d-1of3 ">
                    
                    <a href="https://thefloridacatholic.org/florida-catholic-subscription/ "><img src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/images/flc-footer-laptop.jpg" /></a>
                <h4><a href="https://thefloridacatholic.org/florida-catholic-subscription/ ">Option 1</a></h4>
                
                <p>Fill out the online subscription form <a href="https://thefloridacatholic.org/florida-catholic-subscription/ ">here!</a><br />
Or call toll-free 1-888-275-9953</p>
						</div>

					<div class="m-all t-1of3 d-1of3">
                    
                    <a href="https://thefloridacatholic.org/florida-catholic-subscription/ "><img src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/images/flc-footer-letter.jpg" /></a>
					<h4>Option 2</h4>
                    
                    
                    Send a check payable to: <strong>Florida Catholic</strong><br />
PO Box 4993, Orlando, FL 32802-4993

					</div>

					<div class="m-all t-1of3 d-1of3">
					
<a href="https://thefloridacatholic.org/florida-catholic-subscription/ "><img src="https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/images/flc-footer-tablet.jpg" /></a>
					<h4><a href="https://thefloridacatholic.org/florida-catholic-subscription/ ">Option 3</a></h4>

<p>Subscribe to our <strong>e-Edition</strong> and enjoy<br />Catholic news on any browser.</p>

					</div>
                
                </div>
            
            
            </div>         
            
        
        
        
        
        	<footer class="footer" role="contentinfo" itemscope itemtype="http://schema.org/WPFooter">

				<div id="inner-footer" class="wrap cf">

					<nav role="navigation">
											</nav>

					<p class="source-org copyright">&copy; 2018 Florida Catholic. All rights reserved. <a href="https://thefloridacatholic.org/classifieds/" target="_blank">Classifieds</a> | <a href="https://thefloridacatholic.org/privacy-statement/">Privacy</a>
                    
                    <div class="flc-connect">
                    	Connect with us
                    	<ul>
                    		<li><a href="http://www.facebook.com/FloridaCatholic/" target="_blank"><i class="fa fa-facebook"></i></a></li>
                            <li><a href="https://twitter.com/floridacatholic" target="_blank"><i class="fa fa-twitter"></i></a></li>
                            <li><a href="https://thefloridacatholic.org/feed/" target="_blank"><i class="fa fa-rss"></i></a></li>
                            
                    	</ul>
                    </div>

				</div>

			</footer>

		</div>

				<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/themes/floridacatholic2017/library/js/scripts.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/wp-checkout/views/flc-bootstrap/js/jquery.bootstrap-touchspin.min.js'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/ekko-lightbox/4.0.1/ekko-lightbox.min.js'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/bootstrap-slider/4.10.0/bootstrap-slider.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/wp-checkout/views/flc-bootstrap/js/functions.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/wp-checkout/js/wp-checkout.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/wp-checkout/js/autoheight.js'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/select2/4.0.0/js/select2.min.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-content/plugins/wp-checkout/views/flc-bootstrap/js/jquery.ajaxupload.js'></script>
<script type='text/javascript' src='https://thefloridacatholic.org/wp-includes/js/wp-embed.min.js'></script>

	<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"30f34d75b5","applicationID":"4251470","transactionName":"NgRXZktQWEZSVEJaWw9OdFFNWFlbHERfXVMNBA==","queueTime":0,"applicationTime":1047,"atts":"GkNUEANKS0g=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>

</html> <!-- end of site. what a ride! -->
